Социальные сети

pppoe

23.09.2017
 

Очень интересная картина, имеется c1841 на борту стандартные 2 FE, дополнительно установлены HWIC-1ADSL, HWIC-AP-G-E. Я думаю что все понимают для чего предназначен данный роутер - это просто soho, стоит у меня дома.
Дальше интереснее, IOS 12.4.22 (advSec), adsl терминирует канал от стрима, 1 FE смотрит в сторону voip телефона (avaya) а вот второй FE смотрит в сторону другого провайдера, что самое интересное, оба прова принимают pppoe, со стримом проблем нету, т.е. pppoe поверх atm pvc работает нормально, второй пров работает на чистом ether, после нехитрых настроек получаем вполне рабочий конфиг:
interface FastEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 2
!
interface ATM0/0/0
no ip address
logging event subif-link-status
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
pvc 1/50
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
interface Dialer1
description "Link with хххххххх"
mtu 1460
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1360
dialer pool 1
dialer remote-name хххххххх
no cdp enable
ppp authentication chap pap callin
ppp chap hostname хххххххх
ppp chap password хххххххх
ppp pap sent-username хххххххх
crypto map ipsec-vpn
!
interface Dialer2
description "Link with хххххххх"
mtu 1460
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1360
dialer pool 2
dialer remote-name хххххххх
dialer-group 2
no cdp enable
ppp authentication ms-chap-v2 chap callin
ppp chap hostname хххххххх
ppp chap password хххххххх
crypto map ipsec-vpn

Cмотрим сессии:
#sh pppoe session
2 client sessions

Uniq ID PPPoE RemMAC Port Source VA State
SID LocMAC VA-st
N/A 5621 0030.8800.9210 ATM0/0/0.1 Di1 Vi2 UP
001d.7084.5a4c VC: 1/50 UP

N/A 57691 001e.beff.d054 Fa0/1 Di2 Vi1 UP
001d.7084.5a47 UP
Как видно обе конекции в состоянии UP. Но.

И вот тут начинается самое интересное, pppoe на интерфейсе f0/1 поднята после сессии на интерфейсе ATM0/0/0.1, с сессией всё отлично, но трафик не форвардится через этот ppp канал, я было погрешил на прова, подключил ether к ноуту, и с линукса всё нормально работает, насчет прова я сразу расслабился, и начал копать, в итоге пришел к такому умозаключению:
странным образом циска не понимает в какую сессию просовывать трафик, и как показывает debug она его вообще туда не шлет, стоило погасить stream и переложить default на di2 как канал чудесно зажил. Сижу и думаю 50/50 что мои руки криво что то настроили или всеже БАГ?

dbg?





























































Вам это будет интересно!

  • Kernel


  • Последние новости


    Шаг 5. Выбираем фирменное наименование организации

    Если вы собираетесь регистрировать новое юридическое лицо, то перед вами неизбежно встают необходимость выбора его названия и ряд сопутствующих вопросов. Следует ли проверять выбранное наименование организации на уникальность перед подачей документов на регистрацию? Можно ли зарегистрировать компанию с таким же наименованием, как и у другой, уже существующей орган...
    Читать далее »

    Шаг 4. Выбор системы налогообложения

    Действующее налоговое законодательство позволяет налогоплательщику в некоторых случаях значительно уменьшить сумму уплачиваемых налогов путем грамотного выбора режима налогообложения. Выделяют общий режим налогообложения и специальные налоговые режимы, которые следует отличать от льготных режимов. При применении общего режима налогообложения налог...
    Читать далее »

    Аренда помещений

    Самым тесным образом с фактическим адресом организации связана Аренда Ею помещений, необходимых для налаживания выбранных видов деятельности. Для деятельности любой организации необходимо помещение. Однако недвижимость стоит сейчас очень дорого, и лишь немногие организации в состоянии приобрести помещение в собственность. В связи с этим значительная част...
    Читать далее »

    Шаг 3. Выбираем место нахождения организации

    МЕСТО НАХОЖДЕНИЯ ОРГАНИЗАЦИИ, ЕЕ ЮРИДИЧЕСКИЙ, ФАКТИЧЕСКИЙ И ПОЧТОВЫЙ АДРЕСА В ГК РФ приведено понятие «место нахождения юридического лица» – так называемый юридический адрес, официально зарегистрированный в ЕГРЮЛ. Однако юридическое лицо может располагаться и по другому адресу – фактическому. В гражданском законодательстве не содержит...
    Читать далее »

    Карточка

    С образцами подписей и оттиска печати ...
    Читать далее »

    Форма

    Документа, подтверждающего наличие лицензии Приложение 26 СЕРТИФИКАТ СООТВЕТСТВИЯ ...
    Читать далее »

    Уведомление

    О регистрации юридического лица в территориальном органе Пенсионного фонда Российской Федерации по месту нахождения На территории Российской Федерации Приложение 22 Свидетельство О регистрации страхователя в территориальном фонде Обязательного медицинского страхования При обязательном мед...
    Читать далее »